Projects > cpp > Issues > Bug #1377

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

TMX Tile Cracks in the Test App

Bug #1377 [Closed]
FishFPG 2012-08-08 14:36

Minggo Zhang wrote:

http://www.cocos2d-x.org/boards/6/topics/12508

Here is what I’ve found:

When a TMXLayer is initially created, CCTMXLayer::setupTiles() is called and executes m_pobTextureAtlas->getTexture()->setAliasTexParameters();
However, when the GL Context is lost and is recreated it appears that the texture (referenced by m_pobTextureAtlas->getTexture() is not recreated with AliasTexParameters. The cracks between the tiles occur because the tiles are being drawn Antialiased instead of Aliased.

I have confirmed that if I manually call CCTMXLayer::getTextureAtlas()->getTexture()->setAliasTexParameters() after a GL context switch then cracks between TMX Tiles no longer appear on Android.

zhangxm 2012-08-20 07:43
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:9bd8e7fd95dd6a769f3c75c040b04439b52e16ea.

zhangxm 2012-08-20 07:46
  • Status changed from Resolved to Closed
  • Assignee set to zhangxm

Atom PDF

Status:Closed
Start date:2012-07-02
Priority:Normal
Due date:
Assignee:zhangxm
% Done:

100%

Category:android
Target version:cocos2d-2.0-x-2.0.2

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.