Projects > cpp > Issues > Bug #1409

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

Loading CCControlButton from ccbi failed

Bug #1409 [Closed] 2012-07-29 13:25 . Updated about 4 years ago

Reported and fixed at
It seems the enum value from CCControl.h and CCControlButtonLoader.cpp mismatched. 2012-07-29 14:17

Just fixed it.
So the problem is that:
# The current test suite didn’t cover DISABLED state of CCControlButton
# CocosBuilder v2.0 always generate “4” for CCControlButton::DISABLED state, while the ccb & ccbi file in test suite is manually modified to “3” 2012-07-30 04:26
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:86e3070d6a6ce813e96f916e9275dd31f074d443.

zhangxm 2012-07-30 04:26

Applied in changeset commit:bccaaf0ad803bc9d5b5c51dd65153a45e5ef3604. 2012-07-30 14:27
  • Status changed from Resolved to Closed

Atom PDF

Start date:2012-07-29
Due date:
% Done:


Target version:cocos2d-2.0-x-2.0.2

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.