Projects > cpp > Issues > Refactor #1599

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

CCScrollView and CCTableView Improvement

Refactor #1599 [Closed]
dumganhar 2012-12-06 02:26 . Updated almost 4 years ago

Refers to https://github.com/cocos2d/cocos2d-x/pull/1724.

This pull request fixes an issue with CCScrollView scrolling incorrectly if the container items do not fill or exceed the ScrollView bounds. The issue can be observed by modifying TableViewTestLayer::numberOfCellsInTableView(…) in the ExtensionsTest/TableViewTest project from 20 cells to 2 cells.

This pull request also adds additional functionality to the CCTableView delegates:

  • 1) adds CCTableViewDelegate::tableCellHighlight(…) to inform the delegate that a table cell is currently being pressed. Thus allowing the implementer to highlight the cell or perform some animation and provide visual feedback of the press to the user.

  • 2) adds CCTableViewDelegate::tableCellUnhighlight(…) to inform the delegate that a table cell is no longer being pressed. Thus allowing the implementer to unhighlight the cell or perform some animation and provide visual feedback of the release to the user.

dumganhar 2012-12-06 04:00
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:f65ff69694491748a8efcd959f74aa04271a8a97.

zaWasp 2012-12-18 13:35

Does it also fix these issues?
http://www.cocos2d-x.org/boards/18/topics/17913

James Chen wrote:

h3. Refers to https://github.com/cocos2d/cocos2d-x/pull/1724.
>
This pull request fixes an issue with CCScrollView scrolling incorrectly if the container items do not fill or exceed the ScrollView bounds. The issue can be observed by modifying TableViewTestLayer::numberOfCellsInTableView(…) in the ExtensionsTest/TableViewTest project from 20 cells to 2 cells.
>
This pull request also adds additional functionality to the CCTableView delegates:
>
* 1) adds CCTableViewDelegate::tableCellHighlight(…) to inform the delegate that a table cell is currently being pressed. Thus allowing the implementer to highlight the cell or perform some animation and provide visual feedback of the press to the user.
>
* 2) adds CCTableViewDelegate::tableCellUnhighlight(…) to inform the delegate that a table cell is no longer being pressed. Thus allowing the implementer to unhighlight the cell or perform some animation and provide visual feedback of the release to the user.

dumganhar 2012-12-19 10:03

Yes, it was fixed.

zaWasp 2012-12-23 11:47

Actually it wasn’t. The issue is still there:

  • add empty data source
  • add items to data source
  • call reloadData() => Listview is not visible.

Atom PDF

Status:Closed
Start date:2012-12-06
Priority:Normal
Due date:
Assignee:dumganhar
% Done:

100%

Category:all
Target version:cocos2d-2.1beta3-x-2.1.1

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.