Projects > cpp > Issues > Refactor #2434

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

Add a tool to generate sample Android.mk

Refactor #2434 [Closed]
zhangxm 2013-08-04 00:47
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:71a2cb729264a7a90b74517be2a2745a50a5a977.

zhangxm 2013-08-05 03:52
  • Subject changed from Using better way to list cpp files in Android.mk to Add a tool to generate sample Android.mk
  • Status changed from Closed to In Progress

@Surith said
>> Using shell commands in a makefile is fine if we are building on a known system. However Cocos is built on multiple platforms (Linux, OSX, Windows) each of which could have different shells (bash, Cygwin bash) and with different versions of find, with different line endings (windows vs. unix line endings), etc. The situation is further complicated by user customizations. For example, some users will change the default shell to ā€˜Cā€™ shell which will affect the shell command in GNU Make.

>> Is it necessary to auto generate file dependencies? Yes it is tedious to maintain lists of source files in Android.mk but it is also simple.It is better than having to debug problems in makefiles caused by unknown platforms.

>> So, I would recommend keeping makefiles as dumb lists.

>> If we do need to auto-generate makefiles we should use a platform that is designed to work the same across different environments - such as Python + GyP.

And i think it is right. We should use less platform-dependent codes. So i will change the title and create tools to auto-generate Android.mk.

zhangxm 2013-08-19 02:34
  • Assignee changed from zhangxm to boyu0
boyu0 2013-08-22 14:19
  • Status changed from In Progress to Closed

Applied in changeset commit:16c246cab040248fefbb0e7682b67480c97b2e41.

Atom PDF

Status:Closed
Start date:2013-07-27
Priority:Normal
Due date:
Assignee:boyu0
% Done:

100%

Category:android
Target version:3.0-alpha0

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.