Projects > cpp > Issues > Bug #2920

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

IPA packed by Xcode5 may crash on iOS7 when switching to voice recognition input method

Bug #2920 [Closed]
walzer@cocos2d-x.org 2013-10-10 10:31 . Updated almost 3 years ago

Reported from Weibo http://weibo.com/2283364214/Admudn0wZ

version: cocos2d-x v2.1.5
IPA packed by Xcode5 may crash on iOS7, while package from Xcode4 works correctly.
Crash condition: enable virtual keyboard, then switch to voice recognition input method.

walzer@cocos2d-x.org 2013-10-10 10:31
  • File deleted (Screen Shot 2013-10-10 at 6.27.22 PM.png)
zhangxm 2013-11-16 10:01
  • Assignee changed from zhangxm to WenHai

I have connected the developer that reported the bug on weibo.
Steps to reproduce it is
1. run TestCpp
2. enter ExtensionsTest/EditBoxTest
3. click voice inputing button on keyboard.

@wenhai
You know this bug well, right?

zhangxm 2013-11-16 10:01
  • Target version changed from 3.0-alpha1 to 3.0-beta
Daivuk 2013-11-29 15:35

Hi Guys,

I am running into the same problem. And to me this seems like Apple might reject the App right away for something like that. I’m looking at ways to fix it on my side, but I think we need more eyes on this.
Also do they still accept games packaged with an older iOS sdk? I don’t think packaging with xcode4 is the solution.
And this is certainly a BLOCKER for anyone using textfield in their game. Can we raise the priority on this?

Thanks!

Daivuk 2013-11-29 15:35

[deleted] duplicate post

zhangxm 2013-12-02 01:55
  • Priority changed from Normal to High
zhangxm 2013-12-03 06:02
  • Assignee changed from WenHai to boyu0
LeoTx 2013-12-20 20:03

Hi, I see Apple will start rejecting apps on Feb 1 that aren’t built with the latest Xcode, “Starting February 1, new apps and app updates submitted to the App Store must be built with the latest version of Xcode 5 and must be optimized for iOS 7.”

Is there a timeframe for having a fix for this? Since our current workaround has been to build with Xcode 4.6, if there’s not going to be a cocos2d fix in the January timeframe, we need to come up with some other plan (though not sure what that would be). Thanks.

zhangxm 2013-12-30 02:34

We have temporary resolved it by changing keyboard style by this pull request. We don’t know how to fix it correctly. There is less information about the information.

zhangxm 2014-01-05 08:14
  • Target version changed from 3.0-beta to 34

Should fix it elegantly in future. So i won’t close this issue.

LeoTx 2014-01-22 18:30

Hi, thanks for this option of disabling the microphone. But in our games’ chat feature, the mic is very commonly used. And we risk getting a great deal of unfavorable feedback by removing it.

If possible, please keep this bug as high priority.

LeoTx 2014-01-22 18:49

One note… when I’m running a Dev build on my 7.0 device (installed by xcode while the device is tethered), it works fine. But when running an AdHoc or app store build, it crashes. Hope that helps.

Daivuk 2014-01-22 19:29

I agree with Leon, this is a very critical bug. But i have a feeling that iOS just kills OpenGL context when you press Siri. So it might simply be impossible to fix. Would be nice to have some feedback from Apple on this.

Also: Unlike Leon, I do get the crash from xcode also, not just AdHoc.

LeoTx 2014-01-22 20:34

I like the idea of having some dialog with Apple on this. I am happy to use one of our support incidents, but I don’t think I’m the right person to have that dialog. OpenGL and even Cocos2d are black boxes to me.

zhangxm 2014-01-26 10:18
  • Description updated (diff)
  • Target version changed from 34 to 3.0-rc0
dumganhar 2014-02-21 05:48
  • Status changed from New to Resolved
dumganhar 2014-02-21 05:48
  • Status changed from Resolved to Closed

Atom PDF

Status:Closed
Start date:2013-10-10
Priority:High
Due date:
Assignee:boyu0
% Done:

0%

Category:ios
Target version:3.0-rc0

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.