New issue
 Projects > js > Issues > Bug #3578

Reposting: Strange graphical glitches when canvas element is not wrapped in a div

Bug #3578 [Closed]
ZippoLag 2014-01-03 20:51 . Updated almost 3 years ago

Hi, I’m sorry to do this, but the issue () was closed incorrectly and I see no way of re-opening it or contacting the assigned person for correcting the misunderstanding, so I’m using the “duplicate” button:

In the two following links the exact same code is ran, but in one of the html files the canvas element is wrapped in a div and in the other one it isn’t. Watch how when wrapped the canvas remains a fixed size and everything works well inside it, and when unwrapped the canvas takes up all available space but some sprites malfunction and aren’t shown properly:
http://proto.heart-bit.com.ar/strangeproblem/indexwrapped.html
http://proto.heart-bit.com.ar/strangeproblem/indexnotwrapped.html

Please look at the broken behaviour I show in the image files I’m linking in the folder below. The TMX I’m using for the background appears broken for no apparent reason: http://proto.heart-bit.com.ar/strangeproblem/picsoritdidnthappen/

ZippoLag 2014-01-03 20:56

edit (for explicity, even if redundant): note that I actually like the canvas to expand and fill the entire area, that is not the problem. The problem is how the game’s background breaks.

pandamicro 2014-01-04 02:02
  • Status changed from New to Accepted
  • Assignee set to pandamicro

Sorry, I haven’t noticed that behavior, thank you for duplicating the issue and the testing page!

ZippoLag 2014-01-13 18:46

I’ve updated the code to use v2.2.2 and the problem fixed itself. Whatever it was causing it, it’s no longer a problem, so feel free to close this as resolved.

Thanks!

pandamicro 2014-02-17 08:25
  • Description updated (diff)
  • Status changed from Accepted to Closed
  • Target version set to v3.0 alpha

Atom PDF

Status:Closed
Start date:2013-12-22
Priority:Low
Due date:
Assignee:pandamicro
% Done:

100%

Category:-
Target version:v3.0 alpha

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.