Projects > cpp > Issues > Bug #3727

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

CocosDeshion has a status error when re-entering application

Bug #3727 [Closed]
ludingping 2014-01-16 07:14 . Updated almost 3 years ago

The steps to reproduce the error:
1. Playing a ground music in CocosDenshion Test on iPhone device, and pause the music.
2. Pressing Home button to exit the tests, and the music state is paused.
3. Re-entering the tests app, the music state is playing.

dumganhar 2014-01-16 07:15
  • Assignee set to dumganhar
  • Target version set to 3.0-rc0
dumganhar 2014-01-21 09:01
  • Assignee changed from dumganhar to zhangbin@cocos2d-x.org
zhangbin@cocos2d-x.org 2014-01-21 09:13

The reason of the appearance is:

SimpleAudioEngine::getInstance()->resumeBackgroundMusic()

is invoked in AppDelegate::applicationWillEnterForeground().

zhangbin@cocos2d-x.org 2014-02-27 10:27
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:50547be1f9103849ebe7b461e6219cd082570f78.

Atom PDF

Status:Closed
Start date:2014-01-16
Priority:Low
Due date:
Assignee:zhangbin@cocos2d-x.org
% Done:

100%

Category:ios
Target version:3.0-rc0

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.