Projects > cpp > Issues > Refactor #3781

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

Make binding-generator to support windows.

Refactor #3781 [Closed]
lihex 2014-01-20 03:20 . Updated almost 3 years ago

Current binding-generator on develop branch can only support mac and linux and not support windows.
To make it supports windows we have to make some changes:
1. Add a .bat file instead of .sh to launch generator in tolua/tojs folder.
2. Provide the pre-built libclang-3.4 library for each platform in binding-generator folder, since the 3.4 version was been confirmed as the best choice ( the llvm.org only provide the 3.4 pre-built binaries for windows till now).
3. Show the tips when user is not use Android NDK r9b, since libclang3.4 can only work correctly with r9b.

lihex 2014-01-23 07:57
  • Status changed from New to Resolved
zhangxm 2014-01-26 05:54
  • Description updated (diff)
  • Status changed from Resolved to Closed
  • Target version changed from 3.0-rc0 to 3.0-beta2

Atom PDF

Status:Closed
Start date:2014-01-20
Priority:Normal
Due date:
Assignee:lihex
% Done:

0%

Category:js, linux, lua, mac, windows
Target version:3.0-beta2

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.