Projects > cpp > Issues > Feature #411

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

support .plist format outputed by zwoptex in the last version

Feature #411 [Closed]
walzer@cocos2d-x.org 2011-03-17 03:12 . Updated over 4 years ago

It’s reported that, last version of zwoptex output cannot be parse by cocos2d-x, but works well on cocos2d-iphone 0.99.5
Our source crashes at this line

NSDictionary* metadataDict = (NSDictionary*)dict->objectForKey(string("metadata"));

It may be caused by “metadata”. There’s no “metadata” in the plist

  1. First, fix the crash. I will purchase the last version of zwoptex.
  2. Port the zweptox test cases from cocos2d-iphone 0.99.5
walzer@cocos2d-x.org 2011-03-17 03:12
  • Tracker changed from Bug to Feature
walzer@cocos2d-x.org 2011-03-23 07:34
  • Target version changed from cocos2d-0.99.5-x-0.8.3 to cocos2d-0.99.5-x-0.8.2
zhangbin@cocos2d-x.org 2011-03-29 21:08
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:becd342a7d576fd17edbb514f4c983cd60db77ab.

zhangbin@cocos2d-x.org 2011-03-30 18:41
  • Status changed from Resolved to Closed
walzer@cocos2d-x.org 2012-05-25 08:16
  • Project changed from cocos2d-x to cpp
  • Category deleted (5)
  • Target version deleted (cocos2d-0.99.5-x-0.8.2)

Atom PDF

Status:Closed
Start date:2011-03-17
Priority:Normal
Due date:
Assignee:zhangbin@cocos2d-x.org
% Done:

100%

Category:-
Target version:-

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.