Projects > cpp > Issues > Bug #4129

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

Event listeners in engine shouldn't be removed by method removeAllEventListeners()

Bug #4129 [Closed]
zhangbin@cocos2d-x.org 2014-02-25 07:28 . Updated almost 3 years ago

Now if developer invoked method removeAllEventListeners(), the event listeners in engine will be removed.
It's not correct, the event listeners added in engine framework should not be removed.

There is a problem caused by it: http://cocos2d-x.org/forums/6/topics/45118

zhangxm 2014-02-25 10:23
  • Assignee set to dumganhar
  • Target version set to 3.0-rc0

I think this issue should be fixed in v3.0.

dumganhar 2014-02-28 02:42

OK, I will fix it ASAP.

dumganhar 2014-02-28 18:04
  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:5bf53ec2b48dc8fe7cd7ba5b4bb9b6c8c2852d04.

Atom PDF

Status:Closed
Start date:
Priority:Normal
Due date:
Assignee:dumganhar
% Done:

100%

Category:all
Target version:3.0-rc0

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.