New issue
 Projects > website > Issues > Bug #4386

Tilde shows instead of creating code block in docs

Bug #4386 [Closed]
ZippoLag 2014-03-15 23:26 . Updated over 2 years ago

Here for example: http://www.cocos2d-x.org/docs/manual/framework/html5/v3.0/cc-loader/en
The character reverse tilde shows instead of creating a code-formatted text block.

ZippoLag 2014-03-15 23:28

Aah, I think the problem is because they are used within a triple-tilde block, like this:

something `something` something
eva 2014-03-18 07:04

any problem?

ZippoLag 2014-03-18 17:19

Well.. I'm not sure now.

If there's a way to easily re-filter those kind of messages so they can be highlighted properly it should be done. But if not, I guess it's not such a serious problem.

eva 2014-03-20 08:05

I think the problem is the origin article in here https://raw.githubusercontent.com/cocos2d/cocos-docs/master/manual/framework/html5/v3.0/cc-loader/en.md , the source code is

```script
code

which script is not a real language, so pygment can't hightlighted it properly.

eva 2014-03-31 08:56
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

resolved: if the language cannot highlight properly, then it will just show as text without highlight.

walzer@cocos2d-x.org 2014-05-05 06:59
  • Status changed from Resolved to Closed

Atom PDF

Status:Closed
Start date:2014-03-15
Priority:Low
Due date:
Assignee:-
% Done:

100%

Category:-
Target version:-

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.