Projects > cpp > Issues > Bug #4661

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

setAnimationInterval - Not working on Android or WP8 - Cococs2d-x 3 rc1

Bug #4661 [Closed]
KentuckyFriedKermit 2014-04-02 23:16 . Updated about 2 years ago

director->setAnimationInterval(1.0 / 30);

The above doesn't work on Android or WP8 in any build of Cocos2d-X 3, including RC1.

Instead of limiting the game to 30fps, it continues to run at 60fps.

KentuckyFriedKermit 2014-04-02 23:20

Sorry, this is a duplicate of call 4612. I can't see how to delete mine.

The only difference is that this call mentions WP8. The other call is for Android only.

zhangxm 2014-09-17 07:45
  • Status changed from New to Closed

You can try latest version for Android.
About wp8, there is meaningless, because we use Angle, and its performance is not good.

Atom PDF

Start date:2014-04-02
Due date:
% Done:


Category:android, wp8
Target version:-

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.