Projects > cpp > Issues > Bug #852

We are migrating issue tracker of Cocos2d-x Project to Github, please create new issue there. Thanks.

Create Issue on Github

CCSpriteBatchNode can't be drawn correctly!

Bug #852 [Closed]
dumganhar 2011-11-09 23:54 . Updated over 4 years ago

Test Deivice : bada 2.0 s8600
In the tests demo, LabelTest(Testing empty labels), only show the ‘N’ character, but the correct string is “Not empty”!
And some other demos that use CCSpriteBatchNode also can’t be shown correctly, such as
SpriteTest(SpriteBatchNode transformation);
SpriteTest(SpriteBatchNode openGL Z vertex);
SpriteTest(SpriteBatchNode Z order);
SpriteTest(SpriteBatchNode Color & opacity);
SpriteTest(SpriteBatchNode anchor point)

dumganhar 2011-11-10 19:01

This bug only appear on S8600 device.Other bada device have not this problem:(

dumganhar 2011-11-12 18:59
  • Status changed from New to Resolved
  • % Done changed from 0 to 100

when CCTextureAtlas::resizeCapacity, should

glDeleteBuffers(2, m_pBuffersVBO);
glGenBuffers(2, &m_pBuffersVBO[0]);

otherwise, CCSpriteBatchNode will have a bug the can’t draw more than one sprite on bada 2.0 device. 2011-11-27 06:46
  • Status changed from Resolved to Closed

Please use keywords such as “fixed”, “issue” to link your commitment in github to redmine. 2012-05-25 08:02
  • Project changed from cocos2d-x to cpp
  • Category deleted (8)
  • Target version deleted (cocos2d-1.0.1-x-0.10.0)

Atom PDF

Start date:2011-11-09
Due date:
% Done:


Target version:-

Sign up for our newsletter to keep up with the latest developments, releases and updates for Cocos2d-x.